Australian Coder Warns Users of Lightning Network’s Vulnerabilities

HashFlare

ComputerUniverse Введи промокод FW7FRUX при покупке и получи скидку 5 евро

Australian software programmer and Bitcoin’s (BTC) Lightning Network coder Rusty Russell warned users that “security issues have been found in various Lightning projects which could cause loss of funds.”

Urgent update recommended

On Aug. 30, Russell published a tweet urging LN nodes operators to update their software as soon as possible. According to the message, his warning concerns all versions of c-lightning prior to 0.7.1, lnd older than 0.7, and eclair up to version 0.3.

Notably, just earlier this month blockchain development company Blockstream announced the release of the version 0.7.2 of its BTC scalability software c-lightning.

Details to be released

In a PGP-signed message published on Linux Foundation’s domain Russell explicitly warns users of security issues and promises that more details will be released in the future:

“Full details will be released in 4 weeks (2019-09-27), please upgrade well before then.”

Lightning Network is a second-layer off-chain Bitcoin scalability solution meant to enable instant and near-free BTC payments. Blockstream’s chief strategy officer Samson Mow recently said that Bitcoin is bad for payments, but Lightning Network could solve this. 

As Cointelegraph reported earlier this month, Andreas Antonopoulos announced his new “Mastering Lightning Network” book, co-authored by René Pickhardt and Lightning Labs CTO Olaoluwa Osuntokun.